Results 1 to 6 of 6

Thread: all lights blinking on my roamio basic

  1. #1
    Join Date
    Jan 2019
    Posts
    3

    Default all lights blinking on my roamio basic

    Hey there.
    Roamio just started acting up a couple of weeks ago. Lights in the front started blinking... green, then blue and red... it was making an odd sound so I thought it was the hardrive. I replaced. Now all lights, yellow, green, blue and red are blinking fast. Oh, and the screen is stuck on "welcome."

    I am wondering if it is the internal power supply.
    Thoughts?
    Thanks.

  2. #2
    Join Date
    Nov 2006
    Location
    Los Angeles, CA
    Posts
    6,854

    Default

    Sounds like it might be - start with this info:

    https://www.weaknees.com/bps
    Find us on Twitter and Facebook

  3. #3
    Join Date
    Jan 2019
    Posts
    3

    Default

    Thanks so much for your response. Where do I get a roamio basic power supply?

  4. #4
    Join Date
    Nov 2006
    Location
    Los Angeles, CA
    Posts
    6,854

    Default

    We have them here:

    https://www.weaknees.com/ps
    Find us on Twitter and Facebook

  5. #5
    Join Date
    Jan 2019
    Posts
    3

    Default

    The internal power supplies for the romio basic isn't on here..pro and plus say it wont work...

  6. #6
    Join Date
    Nov 2006
    Location
    Los Angeles, CA
    Posts
    6,854

    Default

    There is no internal power supply on the base Roamio - it's just the external brick.
    Find us on Twitter and Facebook

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •