No announcement yet.

TiVo Premier - Guided Setup failure.

  • Filter
  • Time
  • Show
Clear All
new posts

  • TiVo Premier - Guided Setup failure.

    I have a TiVo Premier that had a dead drive. Black screen, with blinking lights. Drive replaced with a "preloaded" Weaknees HD, and the TiVo fired right back up (Yay!). During guided setup after the drive replacement, it is getting stuck at the "Getting Setup Info" page, on the 3rd step "Getting info". It flashes briefly to 'downloading' then says "connection interrupted".

    Networking is fine, as far as I can tell, no firewalling should be in the way, and this router and ethernet cable worked great for the TiVo 2 weeks ago before the drive failed. I have tried setting the network statically to a known good/open IP address on the network, and I have also set it back to DHCP with no good results.

    My next step is going to be swapping out the BIOS battery as well, in case it is dead and there is a clock/timing issue for the network (even though the "connecting" step #2 says "setting clock" and it gets past that fine...)

    Any ideas!? I'm open for suggestions or fixes, and thanks in advance for any input.

  • #2
    Unlikely it's the battery - I don't think I've ever seen a problem get resolved with a new battery.

    I'd try just rebooting the router for starters. Have you tried that?
    Been here a long time . . .


    • #3
      Yes, router rebooted. Network is confirmed running using that same cable with my laptop, pulling a proper dhcp address. All networking is the same as the last time it was connected/running fine.

      Only change since then has been the replacement of the drive (TiVo was unplugged/ offline for 2 weeks, that is what made me think about the bios battery and clock)


      • #4
        Pretty strange. But I really doubt it's the battery. We have units sitting in our warehouse for years that fire right up and work fine.

        I'd try connecting to a cell hotspot or some other type of network. This really sounds like a networking problem.
        Been here a long time . . .


        • #5
          It is definitely a networking problem. Ive now had the device at 2 different known good networks, with the same result.

          Could it be an incorrect pre-load on the WK hard drive?


          • #6
            Possibly. What does your unit show for the full software version on the system information screen? And what is your exact model number?
            Been here a long time . . .