No announcement yet.

They tried to warn me but I kept my external storage...

  • Filter
  • Time
  • Show
Clear All
new posts

  • They tried to warn me but I kept my external storage...

    I had my TiVo bolt internal drive fail and sent it out to Weaknees to get it repaired, they did an excellent job.

    They gave me the option of a larger internal drive and ditching my external storage, since they said external drives were problematic.

    I had never had an issue so I opted to stick with it which was fine until it failed ...

    It started getting glitchy on playback and the device screen showed that there was no external storage .
    On the next reboot it told me that there was no external drive and I could remove it by using the remote.

    This process did not work and it continues to boot and tell me that there is no external drive and how to remove it which continues not working.

    I have tried the Kickstart codes that should put the unit into a factory reset or at least a reload of the TiVo application but it does not seem to do anything when I do that even though the LEDs indicate that the code was accepted .

    At this point I would just like to get it reset back to having no external drive and a fresh install process but I can't figure out how to do that if I can't get to the main menu to reset things with that option.

    If I pull the drive and perform some type of format on it will that prompt the system to redo the full setup or is there more to it than that.

    I haven't been able to find any instructions on doing a reset at this level and it seems that installing a new larger drive requires nothing but installing physically so I'm not sure what to do to convince it that this is a "new drive" and that it should handle it that way.

    If I pull the drive and attach it to a PC with the SATA interface and just format it or delete the partitions would that be enough to convince it that it was a new drive?

    Any tips would be appreciated.

  • #2
    First, to be clear, we don't think all externals are problematic - just the very old WD DVR Expander drives (max size of 1 TB I think). We think the most stable solution for a Bolt is actually to run with ONLY an external drive now, since the drive itself is full WD Purple line technology, and it's a full-size drive and not a laptop drive.

    Next, have you tried first disconnecting the external physically, and then trying the remove procedure?
    Been here a long time . . .


    • #3
      Ok, thanks for the clarification on the externals.

      Yes, I have completed the clear , 3 thumbs down enter process ( after switching to IR mode on the remote ) and it registered it and said it was removing the drive and not to power off, then it reboots and comes back to the external drive missing on the boot, have tried it several times.

      Was able to reconnect the drive and get it to boot at one point, but the suggested process to unmarry the external is to power it down and disconnect it and follow the instructions that aren't working.

      Can't get it to recognize the external now, just the missing message on boot now.

      I'd be fine with a baseline on the internal drive and live with that storage going forward.


      • #4
        You may also have some sort of failure on the internal.

        I'd try a kickstart 54 overnight test to see how that drive is:

        Been here a long time . . .


        • #5
          I did try that suspecting the same thing, but the LEDs blinked after I put the code in and it didn't do anything but reboot and never showed the drive check screen.

          I did a little digging around and found something that indicated that the 54 doesn't work on the Bolt, I'd have to dig that out but I gave up on that at that point.

          It has run the "green screen" on it's own which just reboots and comes up with the missing external drive message again and I'm back in the same loop with that message.


          • #6
            This was where I found that the bolt may not work with 54.



            • #7
              I just kicked off 57 which started the green screen check, pretty sure I've done that already, but I'll let it run again and report back.


              • #8
                I had left my external attached and I booted back up normally after the green screen pass which it has only done once since I started having issues it.

                I took that opportunity to wipe it with the menu options and it's doing a guided setup again from scratch so we'll see if it cleared the external drive status well enough to boot without it attached.


                • #9
                  We'll, that seems to have worked I'm back in operation without the external and things seem fine so far.

                  Did a reboot from menu with no external and it didn't complain about it so as long as it keeps working we know it was the external starting to fail.

                  First symptoms were hangs in playback, then it saying that it was unable to record the content that was already recorded.

                  Was also reporting that there was no external storage in settings.

                  That was why I decided to ditch it the external and ran into the issues making un-marry and getting into the loop.
                  ​​​​​​We will see what happens from here but so far it's ok.

                  Thanks for the feedback.


                  • #10
                    OK - good luck. Those old fan-less externals do seem to fail sooner than other drives, so that was definitely the most likely scenario here.
                    Been here a long time . . .


                    • #11
                      Looks like it was definitely the external, things have been working perfectly since I was able to convince it not to use it, but it was a frustrating loop that it would not let me remove the non functional drive.

                      I had to reattach it and hope it came up long enough to tell it to factory reset with the remote which seems to have reset the external drive status.

                      Just reiterating for the benefit of anyone else that has a similar issue.

                      Happy TiVo ing all !