No announcement yet.

SAT-T60 Restore Failed, Killed Original Drive!

  • Filter
  • Time
  • Show
Clear All
new posts

  • SAT-T60 Restore Failed, Killed Original Drive!

    I made a MFSTOOLs 2.0 Boot CD from the Hinsdale recommended link for a Series 1.

    I also made a DOS floppy boot disk in XP, and copied the Hinsdale recommended Tivo Disk Unlocking apps on to it.

    I used a HP Pavilion 753n Windows XP computer case to install the drives.
    I disconnected my internal Windows XP C:/ drive.

    Primary IDE Master : an old 4GB drive formatted Fat 32 by Windows XP SP3
    Primary IDE Slave : 40GB Original Tivo Quantum drive
    Secondary IDE Master : HP Pavilion's CD-RW Drive with MFS Tools Boot CD
    Secondary IDE Slave : 120GB Seagate Baracuda New Target Drive Formated NTSF by Windows XP SP3
    (I couldn't get XP SP3 to format as Fat 32 for some reason, does the MFS Tools change the Volume Format to be Tivo compatible?)

    So, I ran the Hinsdale Example 1 steps and made an MFS Tools Backup of the Tivo system to the old 4GB Fat 32 drive. It completed successfully.

    Then I followed the steps to Restore that Backup to the new 120GB drive (which had been formated NTSF by Windows XP SP3.) It completed successfully.

    I forgot to put the Jumper back on the new 120GB disk, and I put it back in the Tivo without the jumper, drive bracket or fan. I powered it up, and it for over 10 minutes, it did not get past the "Powering On" screen.

    I then tried the Original Tivo Drive (also forgot to replace the Jumper) and connected it again without the drive bracket or internal fan connected. After another 15 minutes, it still did not progress beyond the "Powering On" screen.

    Then it occurred to me, that perhaps there is a circuit check to see if the FAN is connected. I replaced the Bracket, plugged the Fan back in and placed the 120GB drive on top of it. Again, without jumpers. Again, 10 minutes at the "Powering On" screen.

    Same for the Original Tivo drive.

    Then I finally remembered the Jumpers!

    I tried each drive, jumped as Master, respectively, and again, stuck at the "Powering On" screen.

    * * *

    So, does anyone have any clue what could've gone wrong? I had no error messages from MFS Tools and I'm REALLY surprised the boot drive got hosed in this process!!!

    The only two things in my case that weren't identical to the Hinsdale guide are:

    The positions of the drives in my computer case.
    BUT, I confirmed all drive letters and capacities by holding Shift+PageUp after the MFS Tools boot prompt, and tripled checked the Drive Letter during every command. (i.e. "hda, hdb, hdd" {hdc=my cd drive} )

    Original TIVO Drive Not Jumpered During Backup
    In my case, I put the Tivo Drive in the Primary Slave position. So I took off the Jumper. Would this have caused any problems during the installation, or caused the drive to be written to?

    * * *

    Any thoughts or possible solutions any of you have would be greatly appreciated.

    I have a Stand Alone Series 2, I'm hoping to upgrade, this SAT-T60 was just a practice run / Proof of Concept, since I don't have DirecTV.
    But at this point, I don't want to move forward on the Series 2, since I've only so far managed to hose the Boot Drive on the DirecTivo.

    Thanks a lot, everyone! BL5K

  • #2
    There's definitely no circuit check - the fan can be completely disconnected and the unit will power up just fine.

    I assume you never booted in XP with either drive attached. XP will wipe part of a partition and render a TiVo drive unbootable in a TiVo.

    I'd check the end of the IDE cable that's connected to the motherboard to be sure it's firmly in place.

    I'd also remove, wipe clean, and carefully reinsert the flat white Parlex cable going from the power supply to the motherboard.

    Post back what you find!
    Been here a long time . . .


    • #3
      Thank you for your response, Michael!

      Wow. I left the DirecTivo sit unplugged on my subwoofer for almost a week and then just tonight, I did some Googling and discovered WINMFS and got the bug to start playing around again.

      I re-examined the original Tivo drive currently connected to the T60. I flipped it back and forth, examining the Jumper pins and comparing them to the Jumper Pin diagram printed on the drive.


      There is a 9th single pin on the original Tivo drive called the "Key" and I was ignoring that and had put the Jumper on BACKWARDS.

      I had also, swapped jumpers between the original drive and the New Larger drive. So I now swapped the jumpers back. Just incase they were slightly different sizes or for some remote possible difference. ;P

      Sure enough, with the Jumper changed, the original drive booted to the ALMOST THERE screen!!! Then it finished. Then I tried to play the recordings. It worked!!! The original drive was totally intact!!!

      * * *

      So then I re-examined the Upgrade Drive I restored the BackUp to. I put it's original Jumper back on. I don't remember though if it was in the same position as before or not. This diagram was much clearer, because it showed the 4 molex power pins in relation to the Jumper pins, so it is curious as to how I could have placed the jumper on incorrectly.

      BUT, sure enough, with the Jumper replaced, the drive did indeed boot to and past the ALMOST THERE screen. I tried to play the recordings, it jumps to the end, asks if I want to delete or save them, I choose, then it tells me there was an Error Playing the Recording.

      i.e. ALL's WELL!!! Everything the Hinsdale Guide Promised worked correctly!

      It was ALL my human error. JUMPER PINS ARE ABSOLUTELY IMPORTANT!!!

      * * *

      I'm just curious, though, does anyone know if the motherboard has some sort of CUDA or reset time limit?

      Did leaving the DirecTivo unplugged for a week allow a battery cache to clear out?

      I'm thinking that maybe none of the drives booted because I first tried them both without Jumpers at all, and maybe the Motherboard remembered that, and that's why it didn't boot the replacement drive originally that first afternoon, even after I had placed the Jumper on?

      I'm just REALLY surprised I put both Jumpers on wrong last week. ( Maybe it WAS switching them back that fixed everything [?], maybe? )

      * * *

      Once again, thank you for your response, Michael. Sorry I made such a fuss over my own user error!


      • #4
        I really don't think so. We pop drives in and out and they work or don't right away. I really think the battery does almost nothing in TiVo units.

        Glad you got it working!
        Been here a long time . . .