No announcement yet.

mfsrestore Restore failed: Unable to open destination device for writing

  • Filter
  • Time
  • Show
Clear All
new posts

  • mfsrestore Restore failed: Unable to open destination device for writing

    Hi -
    I'm currently working on upgrading a TIVO 80GB drive to a 750GB drive.

    The original TIVO drive is connected to IDE as MASTER and the CD-ROM as SLAVE.

    The new drive is connected to SATA.

    Booting off of the Weakness linux cd, All drives are recognized with the correct size.
    Original TIVO: /dev/hda
    CD-ROM: /dev/hdb
    New HD: /dev/hde

    I ran the command:
    mfsbackup -Tao - /dev/hda | mfsrestore -r 4 -xzpi - /dev/hde
    Restore failed: Unable to open destination device for writing.

    Any ideas? I'm computer savvy (and linux too) but I don't know how to overcome this issue.


    p.s. The computer only has one IDE port.

  • #2
    Sounds like there may be a problem with the new drive. Is it brand new? Have you run diagnostics on it?
    Been here a long time . . .


    • #3
      Hi, did you ever get this sorted? Having similar issue-

      Series 3 TiVo- HDD died.

      I got the "virgin" MFS file and burned it to an ISO9660 DVD
      Purchased a Seagate 500GB HDD SATA
      Tried two or three different boot CDs. Here's my process & results, maybe missing something:

      mount /CDROM
      execute: restore -s 127 -zxip /cdrom/tivo.mfs /dev/hdc

      Every time it blows up with some type of space-related issue. SO I also tried the following:
      Ran FDISK with defaults to create partition (then rebooted)
      used mke2fs and mkreiserfs with defaults to format the partition.

      Every time I try the restore, it removes the partition & format but dies right away. What am I missing? Thanks.

      Please note the DVD has the .MFS file on it, and this is a brand new HDD. I don't see this scenario covered in Hinsdale or with any of my searching.

      I'm wondering if having the .MFS file on DVD is what is causing the issue? Do the restore tools try to expand or write some temp data on the source disk? That's what appears to be happening, since the destination clearly is available for writing.


      • #4
        You should be able to restore from a DVD-based image file.

        What's the exact error message?
        Been here a long time . . .


        • #5
          I'm doing this manually, not using Instantcake, but this is the point that the restore is failing. I'll post the error message verbatim tonight, it's something along the lines of "backup has insufficient space"